
 

 
 

 
PDF Accessibility 
Pre-Export Checklists 

 

This guide provides step-by-step accessibility checklists for the most common applications used to create documents that 
will be exported or saved as PDFs. Completing these checks before export prevents the most frequent PDF accessibility 
errors and reduces the need for after-the-fact remediation. 

 

Checklists provided for: 

  • Microsoft Word 

  • Microsoft PowerPoint 

  • Microsoft Excel 

  • Adobe InDesign 

  • Canva 

  • Adobe Acrobat Pro (post-export remediation) 

 

 

 

⚠ These checklists do not replace a full accessibility audit. Use Pope Tech or Grackle Docs to scan exported PDFs and 
verify that issues have been resolved. 

 

💡 The single highest-impact habit: fill in the document Title field before you do anything else. Missing titles account for 
the majority of PDF accessibility errors across all applications. 
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Microsoft Word 
Word has strong built-in accessibility support, but it must be intentionally used. Documents built with manual formatting 
(bold text sized up to look like a heading, for example) instead of proper styles will not export accessible PDFs. 

 

✓ Checklist Item Notes / Where to Find It 

Document Properties 

☐ Set the document Title File → Info → Properties (right panel) → Title 

☐ Set the document Language Review → Language → Set Proofing Language 

☐ Verify the Author field is appropriate for public release File → Info → Properties 

Structure and Headings 

☐ Use built-in Heading styles (Heading 1, Heading 2, etc.) — 
not manual bold/size 

Home → Styles panel 

☐ Heading hierarchy is logical (H1 → H2 → H3, no skipped 
levels) 

View → Navigation Pane to review structure 

☐ Document has exactly one Heading 1 (the document title) Navigation Pane 

☐ Lists use Word's built-in list formatting, not manual hyphens 
or typed bullets 

Home → Paragraph → List buttons 

☐ Table of contents (if present) uses Word's built-in TOC tool References → Table of Contents 

Images and Visual Elements 

☐ Every meaningful image has alt text written Right-click image → Edit Alt Text 

☐ Decorative images are marked as decorative Right-click image → Edit Alt Text → check "Mark as 
decorative" 

☐ Alt text describes content and function, not appearance 
("Chart showing Q3 growth" not "bar chart") 

 

☐ Images are not inside text boxes (text boxes are not 
exported accessibly) 

Move images inline with text 

☐ Text is not placed inside images (logos with text need alt 
text) 

 

Tables 

☐ Tables are used for data, not for layout/formatting  

☐ Tables have a designated header row Click in table → Table Design → check Header Row 

☐ Header row is marked to repeat across pages Table Properties → Row → Repeat as header row 

☐ No merged or split cells (these confuse screen readers)  

☐ Tables have a descriptive caption or title References → Insert Caption, or use a heading above the 
table 

Color and Contrast 

☐ Color is not the only way information is conveyed (e.g., 
"items in red are required") 
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☐ Text color meets minimum contrast against background 
(4.5:1 for normal text) 

Use WebAIM Contrast Checker at 
webaim.org/resources/contrastchecker 

☐ Hyperlinks are distinguishable by more than color alone 
(underline, bold, or other indicator) 

 

Links 

☐ All hyperlinks have meaningful anchor text ("Read the 2024 
report" not "click here" or a raw URL) 

 

☐ URLs that must appear as text are shortened or 
accompanied by descriptive text 

 

Export Settings 

☐ Export via File → Save As → PDF, NOT via Print → Save as 
PDF 

"Save as PDF" preserves tags; "Print to PDF" destroys them 

☐ "Document structure tags for accessibility" option is 
checked in export dialog 

File → Save As → PDF → Options → check this box 

☐ "Document properties" option is checked (carries 
Title/Language metadata) 

Same Options dialog 

☐ Run the built-in Accessibility Checker before export Review → Check Accessibility 
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Microsoft PowerPoint 
PowerPoint exports are among the most commonly inaccessible PDFs because the visual, freeform nature of slide design 
makes proper structure easy to skip. The Reading Order pane is the most important tool to know. 

 

✓ Checklist Item Notes / Where to Find It 

Document Properties 

☐ Set the Presentation Title File → Info → Properties → Title 

☐ Set the Language Review → Language → Set Proofing Language (apply to all 
slides) 

Slide Structure 

☐ Every slide uses a Layout from the Slide Layout panel (not a 
blank slide with text boxes) 

Home → Layout dropdown 

☐ Every slide has a unique, descriptive title Click the title placeholder on each slide 

☐ Slides that intentionally have no visible title use a hidden 
title placeholder 

Insert → Text Box, size to 1px, add title, drag off-slide — or 
use Slide Master 

☐ Slide order is logical and follows the intended reading 
sequence 

View → Slide Sorter 

Reading Order 

☐ Reading order for each slide has been verified using the 
Reading Order pane 

Home → Arrange → Selection Pane (reading order is bottom-
to-top in this panel) 

☐ Text boxes, images, and shapes are ordered so screen 
readers read them in the intended sequence 

Drag items in Selection Pane to reorder 

☐ Decorative shapes/lines that are not content are listed last 
in reading order or marked as decorative 

 

Images and Visual Elements 

☐ Every meaningful image, chart, graph, or SmartArt has alt 
text 

Right-click → Edit Alt Text 

☐ Decorative images are marked as decorative Right-click → Edit Alt Text → Mark as decorative 

☐ Charts and graphs: alt text describes the key takeaway, not 
just what type of chart it is 

"Sales grew 23% in Q3" not "Bar chart" 

☐ SmartArt is converted to text or given comprehensive alt 
text 

SmartArt tab → Convert to Shapes, then add alt text 

Text and Contrast 

☐ All text is in text boxes or placeholders, not embedded in 
images 

 

☐ Font size is at least 18pt for body text (readability standard 
for presentations) 

 

☐ Text color meets minimum contrast against slide 
background 

webaim.org/resources/contrastchecker 

☐ Color is not the only way to distinguish information  

Tables 



PDF Accessibility Pre-Export Checklists WVNET  |  wvnet.edu 

☐ Tables are built using PowerPoint's Insert Table, not drawn 
with lines 

Insert → Table 

☐ Tables have a designated header row Table Design → check Header Row 

☐ Tables are simple (no merged cells)  

Animations and Transitions 

☐ Any content conveyed through animation is also available in 
a static, accessible form 

 

☐ Auto-advance timing is not used (or a non-timed version is 
provided as the accessible PDF) 

 

Export Settings 

☐ Export via File → Save As → PDF (not Print → Save as PDF)  

☐ "Document structure tags for accessibility" is checked in 
Options 

File → Save As → PDF → Options 

☐ "Document properties" is checked Same Options dialog 

☐ Run built-in Accessibility Checker before export Review → Check Accessibility 
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Microsoft Excel 
Excel-derived PDFs are common for reports, data tables, and financial documents. The primary concerns are table structure, 
chart accessibility, and sheet naming. Complex multi-sheet workbooks often need individual attention per sheet. 

 

✓ Checklist Item Notes / Where to Find It 

Document Properties 

☐ Set the Workbook Title File → Info → Properties → Title 

☐ Set the Language Review → Language → Set Proofing Language 

Worksheet Structure 

☐ Each worksheet has a meaningful, descriptive tab name (not 
Sheet1, Sheet2) 

Double-click the tab to rename 

☐ Data begins in cell A1 (no blank rows/columns used as 
spacing) 

 

☐ No blank rows or columns used as visual separators within 
data 

Use cell formatting for visual spacing instead 

☐ Only one data table per worksheet (when possible) Multiple tables on one sheet cause structural issues 

Table Formatting 

☐ Data ranges are formatted as Excel Tables (not just styled 
cells) 

Select data → Insert → Table → check "My table has 
headers" 

☐ Table has a clear, descriptive header row in the first row  

☐ Column headers are descriptive ("Department Name" not 
"Col A") 

 

☐ No merged cells in header row  

☐ Table has a name that describes its contents Table Design → Table Name field 

Charts and Graphs 

☐ Every chart has a meaningful title Click chart → Chart Elements → Chart Title 

☐ Every chart has alt text describing the key data insight Right-click chart → Format Chart Area → Alt Text (Size & 
Properties → Alt Text) 

☐ Axis labels are present and descriptive  

☐ Data labels are used where possible so values don't rely on 
color alone 

 

☐ Chart colors meet contrast requirements Avoid light yellow or light gray data series 

☐ A data table is included below or alongside complex charts Chart Tools → Design → Add Chart Element → Data Table 

Color and Contrast 

☐ Cells do not use color as the only indicator of meaning "Overdue" label + red fill, not red fill alone 

☐ Conditional formatting rules are accompanied by text 
indicators 

 

☐ Text in colored cells meets 4.5:1 contrast ratio webaim.org/resources/contrastchecker 



PDF Accessibility Pre-Export Checklists WVNET  |  wvnet.edu 

Print and Export Settings 

☐ Print area is defined to include only the relevant data Page Layout → Print Area → Set Print Area 

☐ Column and row headers are set to repeat on each printed 
page 

Page Layout → Print Titles 

☐ Export via File → Save As → PDF  

☐ Run built-in Accessibility Checker before export Review → Check Accessibility 
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Adobe InDesign 
InDesign has the most robust PDF accessibility export of any design tool — but only when documents are built with 
structured styles and the Articles panel is used. InDesign files built with manual formatting instead of paragraph styles will 
require significant remediation regardless of export settings. 

 

⚠ InDesign accessibility requires intentional setup during document creation. There is no shortcut for a document built 
without paragraph styles — the structure must be added before export will produce usable tags. 

 

✓ Checklist Item Notes / Where to Find It 

Document Setup 

☐ Document has a Title set in File → Document Properties File → Document Properties → Description 

☐ Document language is set Edit → Preferences → Dictionary → Language 

Paragraph and Character Styles 

☐ All body text uses a named Paragraph Style (not "No 
Paragraph Style") 

Window → Styles → Paragraph Styles 

☐ All headings use dedicated Heading styles (Heading 1, 
Heading 2, etc.) 

Paragraph Styles panel 

☐ Heading styles are mapped to PDF export tags (H1, H2, H3) Paragraph Styles → Edit Style → Export Tagging → PDF Tag 

☐ Body text style is mapped to the <P> export tag Same — Edit Style → Export Tagging 

☐ List styles are mapped to <L>, <LI>, <LBody> export tags Edit Style → Export Tagging for each list style 

☐ No text is formatted manually without a style (no ad-hoc 
bold used as a heading) 

 

Images and Figures 

☐ All meaningful images have alt text set Select image → Object → Object Export Options → Alt Text 
tab 

☐ Alt text source is set to "Custom" and meaningful text is 
entered 

Object Export Options → Alt Text → Custom 

☐ Decorative images are marked as artifacts Object Export Options → Tagged PDF tab → Apply Tag: 
Artifact 

☐ Image frames are not stacked in a way that creates false 
reading order 

 

Reading Order (Articles Panel) 

☐ Articles panel is open and in use Window → Articles 

☐ All content (text frames, images) is added to one or more 
Articles in reading order 

Drag frames into Articles panel in sequence 

☐ Decorative elements are excluded from Articles (or tagged 
as Artifact) 

 

☐ "Use for Reading Order in Tagged PDF" is checked in Articles 
panel options 

Articles panel menu → Panel Options 

Tables 
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☐ Tables are created with InDesign's Table tool, not manually 
drawn lines 

Table → Insert Table 

☐ Header rows are designated using Table → Cell Options → 
Rows and Columns → Row Type: Header 

 

☐ Tables are not used for layout (use text frames in a grid 
instead) 

 

Hyperlinks 

☐ All hyperlinks have descriptive text (not bare URLs) Window → Interactive → Hyperlinks 

☐ Hyperlinks are active links, not just styled text Hyperlinks panel shows the link 

Export Settings 

☐ Export via File → Export → PDF (not File → Print → Save as 
PDF) 

 

☐ PDF Export Preset is set to PDF/UA or Accessibility-focused 
preset 

Or configure settings manually in the Interactive/Print dialog 

☐ "Create Tagged PDF" is checked Export dialog → General tab 

☐ "Use Structure for Tab Order" is checked Export dialog → Interactive PDF settings 

☐ "Create Acrobat Layers" is unchecked (layers complicate 
accessibility) 

 

☐ Hyperlinks and Bookmarks are included in export Export dialog → General tab → Include options 

☐ View PDF After Export to spot-check reading order in 
Acrobat 
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Canva 
Canva is a popular design tool with significant accessibility limitations. It does not support document structure tagging, 
heading hierarchy, or reading order control in its PDF export. PDFs exported from Canva will almost always require 
remediation in Acrobat Pro before they meet accessibility standards. 

 

⚠ Canva PDFs are not natively accessible. There is no way to export a fully tagged, structured PDF from Canva. Treat 
every Canva PDF export as requiring post-export remediation in Acrobat Pro. For long documents or content that 
must meet compliance requirements, consider building in Word or InDesign instead. 

 

That said, following these practices in Canva will minimize remediation time: 

 

✓ Checklist Item Notes / Where to Find It 

Before You Design 

☐ Consider whether Canva is the right tool — for long text 
documents, Word produces far more accessible PDFs with 
less effort 

 

☐ If using Canva for a one-page flyer or certificate, plan on 
opening the exported PDF in Acrobat Pro for remediation 

 

Text and Readability 

☐ All meaningful text is actual text (not an image of text) Canva will export typed text as selectable text if not 
flattened 

☐ Text color meets 4.5:1 contrast against its background Use WebAIM Contrast Checker or Canva's built-in color 
picker to verify 

☐ Font size is at least 12pt for body content  

☐ Text is not overlaid on busy or photographic backgrounds 
without sufficient contrast 

Add a semi-transparent overlay or text shadow if needed 

☐ Avoid text placed inside images or rendered as part of a 
graphic element 

Text in downloaded image files cannot be read by screen 
readers 

Images 

☐ Make a list of all meaningful images in your design before 
exporting — you will need to add alt text in Acrobat 

Canva does not support alt text in its editor 

☐ Note which images are decorative vs. meaningful so you can 
mark them correctly in Acrobat 

 

☐ Avoid placing images in Canva's background layer if they 
convey meaning (background images are often treated as 
artifacts) 

 

Color and Design 

☐ Information is not conveyed by color alone "Required fields marked in red" must also have another 
indicator 

☐ Charts and graphs include data labels so values are readable 
without color 

 

☐ Sufficient white space is used so the visual hierarchy is clear 
(this makes remediation easier) 

 

Export Settings 



PDF Accessibility Pre-Export Checklists WVNET  |  wvnet.edu 

☐ Export as PDF Standard (not PDF Print) to reduce file size 
issues 

Share → Download → PDF Standard 

☐ After export, open immediately in Acrobat Pro and run 
Accessibility Checker before distribution 

See the Acrobat Pro checklist on the following page 

☐ Add document title and language in Acrobat Pro after export 
(Canva does not set these) 

File → Document Properties in Acrobat 

 

💡 For Canva documents you export regularly (a monthly newsletter template, for example), consider building a 
remediation "action" in Acrobat Pro that handles the repetitive fixes automatically each time. 
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Adobe Acrobat Pro — Post-Export Remediation 
Use this checklist after receiving a PDF from any source — either your own export or a document received from a third 
party — before publishing it to a public-facing website. This is also the primary remediation tool for legacy PDFs and Canva 
exports. 

 

💡 Run the Accessibility Checker first (All Tools → Prepare for Accessibility → Check for Accessibility Issues). Use its report 
as your issue list, then work through the fixes below. Re-run the checker after each major fix to confirm issues are 
resolved. 

 

✓ Checklist Item Notes / Where to Find It 

Document Properties (Always Fix First) 

☐ Document Title is set and descriptive File → Document Properties → Description tab → Title field 

☐ "Show: Document Title" is set in Initial View (not File Name) Document Properties → Initial View tab → Show dropdown 

☐ Document Language is set Document Properties → Advanced tab → Reading Options → 
Language 

☐ Document Author is appropriate for public release Document Properties → Description tab 

Tagging 

☐ Document is tagged (PDF has structural tags) Accessibility Checker will flag this; File → Document 
Properties → Description → "Tagged PDF: Yes" 

☐ If untagged: run Auto-Tagger as a starting point All Tools → Prepare for Accessibility → Automatically Tag 
PDF 

☐ Tag tree has been reviewed for accuracy in the Tags panel View → Show/Hide → Navigation Panels → Tags 

☐ Decorative elements (rules, borders, background shapes) 
are marked as Artifacts 

All Tools → Prepare for Accessibility → Reading Order → 
select element → Background/Artifact 

☐ "Path object not tagged" errors are resolved by marking 
paths as Artifacts 

Same Reading Order tool 

Headings 

☐ Document has exactly one H1 (the document title) Tags panel 

☐ Heading levels do not skip (H1 → H2 → H3, never H1 → H3) Tags panel — right-click a tag to change its type 

☐ Text that is visually a heading is tagged as a heading (not a 
<P>) 

Tags panel → right-click → Properties → change tag 

Alternative Text 

☐ All meaningful images have alt text All Tools → Prepare for Accessibility → Set Alternate Text 

☐ Decorative images are marked as decorative figures Set Alternate Text → check "Decorative Figure" checkbox 

☐ Alt text describes content and function, not appearance "Q3 sales bar chart showing 23% growth" not "chart image" 

☐ Alt text for annotations (form fields, links) is meaningful Tags panel → <Link> or <Form> elements → Properties → 
Alternate Text 

Reading Order 

☐ Reading order has been verified using Read Out Loud or an 
actual screen reader 

View → Read Out Loud → Read This Page Only 
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☐ Multi-column layouts read in the correct column order (left 
column, then right) 

Reading Order tool can be used to fix column sequence 

☐ Page headers/footers are tagged as Artifacts (not read as 
content) 

Tags panel or Reading Order tool 

☐ Page numbers are tagged as Artifacts Same as above 

Tables 

☐ Tables are tagged with <Table>, <TR>, <TH>, and <TD> tags Tags panel 

☐ Header cells use <TH> tags (not <TD>) Right-click in Tags panel → Properties → change to TH 

☐ Table cells have appropriate scope attributes (Column/Row) Right-click TH in Tags panel → Properties → Attribute → 
Scope 

Links and Hyperlinks 

☐ All hyperlinks have descriptive alternate text or are 
embedded in descriptive anchor text 

Tags panel → <Link> elements → Properties → Alternate 
Text 

☐ Bare URLs are given a descriptive label in the tag's alternate 
text 

 

Color Contrast 

☐ Text color meets minimum contrast requirements against 
background 

Use WebAIM Contrast Checker — PDF colors can be sampled 
with Acrobat's color tools 

Final Validation 

☐ Accessibility Checker passes with no Errors (Warnings may 
remain) 

All Tools → Prepare for Accessibility → Check for Accessibility 
Issues 

☐ Document has been validated with PAC 2024 (free third-
party checker) 

Download at pac.pdf-accessibility.org 

☐ Document has been tested with Read Out Loud or a screen 
reader 

View → Read Out Loud in Acrobat 

☐ File has been saved after all changes File → Save (not Save As, unless creating a new version) 

 

Additional Resources 

WebAIM Contrast Checker: webaim.org/resources/contrastchecker 

PAC 2024 PDF Checker: pac.pdf-accessibility.org 

WebAIM PDF Accessibility Guide: webaim.org/techniques/acrobat 

Grackle Docs (Google Docs accessibility): grackledocs.com 
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